File “/usr/local/bin/ride.py”, line 20, in 错误

最近在mac 中安装robot-faeamework的时候 ,无法启动。

错误信息如下:

Traceback (most recent call last):
File "/usr/local/bin/ride.py", line 20, in ?
from robotide import main
ImportError: No module named robotide

因为是mac 端,google 找了半天,官方这个issues 还是open 状态。
https://github.com/robotframework/RIDE/issues/1647

找了半天终于找到解决办法。出现这个错误的原因不是因为没有安装robot-faramework, 而是因为主机中存在多个python 版本。

python2 是/usr/local/bin/pyhon

python3 是/usr/local/bin/pyhon3

只需要强制执行 python /usr/local/bin/ride.py 即可。

默认使用 ride.py 是不行的。

发表评论

电子邮件地址不会被公开。 必填项已用*标注